AnsweredAssumed Answered

Configuring Two RH6 Servers To One Initiator Group

Question asked by Brent Gunn on Sep 15, 2014
Latest reply on Sep 17, 2014 by aquaman

Greetings,

 

I need help to configure one initiator group (contains three volumes) on two physical RH6 machines.  This group contains one volume for machine 1 and another unique volume for machine 2.  These two volumes have been configured and working for almost a year with no issues...again one each volume to one each machine.  We added a third volume to the initiator group and want it to mount to both machines.  I was able to present it to the first machine and configure the LVM on the new/third volume as well as create the fstab entry.  On reboot to test persistence, neither the original volume that was working nor the new volume would mount as RH said it could not find the drives.  Turned out, either the way I added or configured the device caused the drive designators to change so when the RH tried to load the volumes, they drives didn't match what was expected from the LVM and they would not load.

 

Also, prior to restarting the configured machine, I was able to get the third volume presented to the second machine (connections via iSCSI btw) but could not get the machine to read the volume that was already configured with the LVM.  When trying to display the lv, vg or pv...they kept skipping the volume/LVM.  I realize all of this may not be a storage/Nimble issue and more of a linux admin issue but I am unclear on where to start as I am new to network storage and iSCSI.

Outcomes